注册账号登录
关注

开发环境运行问题

我是windows环境运行,在启动的过程中报import错误,我看了下import的文件是存在的请问是怎么回事

3条评论 / 6条回复

请提供一下错误截图,我看看错误是什么.

回复


node版本 8.11.1

回复

https://github.com/54sword/admin.xiaoduyu.com/blob/master/.babelrc

应该是缺少这个文件,在根目录添加这个文件,然后再试一试

3月21日
回复

有这个文件的

3月21日
回复

还有个问题,如果是windows环境的话 那个设置环境变量的脚本也会报错

3月21日
回复

额,从错误上看,是没有识别 import,应该是和 .babelrc 有关系。

我这边没有你的错误环境,不能调试,你可以沿着个思路,调试一下看看。

3月21日
回复

可以试一试使用 cross-env 来设置环境变量

https://github.com/kentcdodds/cross-env

3月21日
回复

后台管理工程 其他的都可以运行

回复

我之前后端在windows下也跑不起来,建议在linux下尝试

3月21日
回复
zhangds
关注私信
0
关注
0
粉丝
1
帖子